読者です 読者をやめる 読者になる 読者になる

Mae向きなブログ

Mae向きな日記のブログ版。ようやくこちらに移行してきました。

Xcodeのバージョンアップ

Mac

graphvizをアップグレードしようと思ったら…,

before

$ sudo port upgrade graphviz

      • > Activating xorg-renderproto @0.9.3_0

Error: Target org.macports.activate returned: Image error: /opt/local/include/X11/extensions/render.h is being used by the active render port. Please deactivate this port first, or use 'port -f activate xorg-renderproto' to force the activation.
Error: The following dependencies failed to build: xorg-renderproto
Error: Unable to upgrade port: 1

Error: On Mac OS X 10.5, graphviz 2.22.2 requires Xcode 3.1.2 or later but you have Xcode 3.0.
Error: Target org.macports.extract returned: incompatible Xcode version
Error: Unable to upgrade port: 1

Xcodeをバージョンアップしないといけないようです。
ということで,以下を参考にXcodeをバージョンアップしました。ファイルサイズは,995.8MBでした。

after

$ sudo port -f activate xorg-renderproto
$ sudo port upgrade graphviz

      • > Fetching xrender
      • > Attempting to fetch libXrender-0.9.4.tar.bz2 from http://www.x.org/archive/individual/lib/
      • > Verifying checksum(s) for xrender
      • > Extracting xrender
      • > Configuring xrender
      • > Building xrender
      • > Staging xrender into destroot
      • > Deactivating xrender @0.9.0_2
      • > Installing xrender @0.9.4_5
      • > Activating xrender @0.9.4_5
      • > Cleaning xrender
      • > Building graphviz
      • > Staging graphviz into destroot
      • > Deactivating graphviz @2.20.2_0+darwin_9
      • > Installing graphviz @2.22.2_0+macosx
      • > Activating graphviz @2.22.2_0+macosx
      • > Cleaning graphviz

無事,終了です。