Mae向きなブログ

Mae向きな日記のブログ版。ようやくこちらに移行してきました。

etch->lenny

ブラウザ上で写真のスライドショーのようなものを作るようにと頼まれたので,どんな感じで作ろうかと調べたのですが,いろいろなJavascriptライブラリがあるみたいです。その中から,Highslide JSが良さそうなので使ってみようと思います。
この仕事を頼まれたとき,デザインのセンスがないので,少し不安でしたが,なんとかなりそうな気がしてきました。ゴールがある程度見通せると,寄り道したくなるもので,久しぶりに,aptitude update したら以下のようなエラーが出ました。

debian:~# aptitude update
取得:1 http://ftp.jp.debian.org etch Release.gpg [1032B]
取得:2 http://www.jp.backports.org etch-backports Release.gpg [189B]
ヒット http://ftp.jp.debian.org etch Release
(途中略)
パッケージリストを読み込んでいます... 完了
W: GPG error: http://ftp.jp.debian.org etch Release: 公開鍵を利用できないため、 以下の署名は検証できませんでした: NO_PUBKEY 9AA38DCD55BE302B
W: There is no public key available for the following key IDs:
9AA38DCD55BE302B

以下のように対処。

debian:~# gpg --keyserver wwwkeys.eu.pgp.net --recv-keys 9AA38DCD55BE302B
debian:~# gpg --armor --export 9AA38DCD55BE302B | apt-key add -
OK
debian:~# aptitude update

こんどはうまくいきました。ここまでやったところで,etchからlennyにバージョンアップしたくなったので,

debian:/etc/apt# ruby -p -i.bak -e 'gsub("etch", "lenny")' sources.list
debian:~# aptitude update
debian:~# aptitude install aptitude
debian:~# aptitude safe-upgrade
debian:~# aptitude full-upgrade

ちょっと寄り道のつもりが…。相当,時間がかかりました…。